Wordpressのインストール・カスタマイズ・不具合の復旧致します。
サーバー移管・テーマのご提案等も可能です。Wordpressのトータルサポート
wordpress

phpのバージョンを変更したら、「お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。」と出てサイトが表示出来ない問題。

今回の作業事例

今回は、phpのバージョンを変更したら、「お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。」と出てサイトが表示出来ない問題です。

不具合の確認

通常は、サーバーコントロールパネルでphpのバージョンを変えて何か不具合が出ても、phpのバージョンを戻せば済むのですが、戻してもエラーが出て戻せない状態に陥っていました。

原因は?

今回のFUTOKAサーバーとコアサーバーでのみ起こる「サーバーの初期設定」が原因でした。

サーバー側の問題でした。

復旧作業「php.ini設定を変更」する

この中の、

———————————————————————
extension_dir = “/usr/local/lib/php/extensions/●●●●●●●●●●●●●●●●●●●
———————————————————————

▼コメントアウトする!
———————————————————————
;extension_dir = “/usr/local/lib/php/extensions/●●●●●●●●●●●●●●●●●●●
———————————————————————

「;」これを足しただけです。(笑)

 

まとめ

ただ、php.ini設定は色々な設定が沢山ありますので、間違って削除したり書き損じたりしないように注意して作業を行なって下さい。

初めての事例で、しかも情報もかなり少なかったのでレアケースのようです。

にほんブログ村 IT技術ブログ WordPressへ

COMMENT

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です